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10 Steps to Evaluating QNX and Momentics IDE
Symmetry Innovations is the distributor of QNX in Australia and New Zealand. For the benefit of the QNX
prospects, Symmetry Innovations has enabled evaluation of QNX RTOS and Momentics IDE over the internet. This
will benefit prospects who wants immediate access to QNX RTOS and Momentics IDE without spending time on
setup and installation.
Following versions are available for evaluation over the internet.
•• QNX 6.6 RTOS
•• QNX Momentics IDE 5.0
Ask us for access. You can do it in one of the four simple ways.
1.1. Send email to info@symmetry.com.au and request access OR
2. Go to http:/ / qnx. symmetry. com. au/ qnx-trial. html and fill up the form OR
3. Generate a New Support Ticket requesting access at http:/ / support. symmetry. com. au OR
4.4. Phone +61-262486611 and ask for QNX Evaluation.

Step 1: Requirements
Following setup is a minimum requirement for a prospect who wants to evaluate QNX RTOS and Momentics IDE
over the internet.
•• PC
• Team Viewer Client (available from http:/ / www. teamviewer. com)
•• Internet Connection

Step 2: Evaluation Machine Details
As part of the evaluation you would be evaluating QNX RTOS and Momentics IDE. Both are installed on separate
virtual machines.

QNX RTOS
QNX RTOS is installed as a virtual machine. The details of the virtual machine are as under.

 IP Address  : 10.1.1.3

 Username    : guest

 Password    : guest

Momentics IDE
Momentics IDE is installed on a Windows 7 Virtual Machine. The details of the virtual machine are as under.

 IP Address           : 10.1.1.2

 Windows Login As     : Guest

 Windows Password     : None

 Team Viewer ID       : Provided in a separate e-mail

 Team Viewer Passowrd : Provided in a separate e-mail

http://qnx.symmetry.com.au/qnx-trial.html
http://support.symmetry.com.au
http://www.teamviewer.com)
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Step 3: Getting Started with Evaluation
The below steps would get you started with the evaluation machines over the internet.

Connect
•• Open up the team viewer client on you PC and connect to the QNX tools using the given Team Viewer ID and

password. (Please note that Team Viewer ID and password would be provided in a separate e-mail)
•• On successful connection you will see a Windows 7 login screen. You have the luxury to work in full screen if

required.

Log in
•• Login as Guest (You won't be asked for a password)
•• After successful login you will see a Windows 7 desktop.

Step 4: Familiarize with Windows 7 Desktop
You will notice the following four important icons on the desktop apart from Recycle Bin.

Bitvise SSH Client
This can be used to ssh into the QNX machine and upload/download files by using the following credentials.

 Host        : 10.1.1.3

 Port        : 22

 Username    : guest

 Password    : guest

QNX Momentics IDE 5.0
This is the QNX Momentics Integrated Development Environment (IDE), which can be used for writing code and
targeting the QNX machine.

ide-5.0-workspace
This is a shortcut to the Momentics IDE default workspace where all your projects are stored. The actual path is
"C:\Users\Guest\ide-5.0-workspace".

My Documents
This is a shortcut to the My Documents folder of the Guest User Account where you can store your miscellaneous
data. The actual path is "C:\Users\Guest\Documents".
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Step 5: Copying Files
Files can be copied to and fro from all the three machines involved i.e. Your PC, Momentics IDE Windows 7
Machine and QNX Machine.

Windows 7 <-> QNX
Files from Windows 7 and QNX can be copied to and fro by using the Bitvise ssh client. Once connected to the
QNX Machine via Bitvise SSH Client, use the "New SFTP Window" within Bitvise SSH Client to move files
around.

Your PC <-> Windows 7
Files from your PC and Windows 7 can be copied by using the Team Viewer File Transfer mechanism. The Team
Viewer File Transfer icon can be located on the top panel when you are connected to Windows 7 machine.

Step 6: Launch and Familiarize with Momentics IDE
The below steps would help you in launching the Momentics IDE and familiarizing with it.

Launch
To launch the Momentics IDE, double click on the "QNX Momentics IDE 5.0" icon on the Desktop. This will open
up the Momentics IDE.

Familiarize
•• The IDE will look familiar to you if you have used Eclipse before.
•• Momentics has different "Perspectives" for different jobs.
•• "Perspectives" are nothing but just the layout and arrangement of the relevant IDE components on the limited real

estate of visible space.
• To see and open different perspectives, click on "Window -> Open Perspective -> ..."
There are several perspectives but few of them that might be of interest are listed below.

C/C++ Perspective

•• This is the default perspective that you will see when Momentics IDE is launched.
•• It can be used to write C/C++ code.
•• You would see QNX targets and Projects on the left pane.
•• You can create new projects and files here.
•• You can "Build" and "Clean" projects here.
•• You can "Run" projects here.
•• You can start "Debugging" the projects here.
•• The console output can be visible on the bottom pane.
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Debug Perspective

•• This is the default perspective that will open up automatically when you start "Debugging" a project.
•• You can "Debug" the program here by doing "Step into", "Step over", etc.
•• Here you can create "Break Points", "Variables Watch", etc.
•• The console output can be visible on the bottom pane.

QNX System Information Perspective

•• You would see QNX targets on the left pane.
•• Expanding the target will show you all the process running under that target.
•• On the right pane, you would be able to see different tabs like "System Summary", "Process Information",

"Memory Information", "Malloc Information", "Target File System Navigator", etc which are self explanatory.
Try them out.

•• You can also add new targets by right clicking on the left pane, provided that the targets are already connected to
the network physically.

Step 7: Explore and Run Pre-installed Targets and Projects
When you launch Momentics IDE, you will find one target and three projects on the left pane that are pre-installed
by Symmetry Innovations. There is a README File in each project that you will see when you expand the projects
on the left pane.

Target: 10.1.1.3 (QNX 6.6 VM)
•• A QNX Virtual Machine Target is pre-installed for you to play i.e. "10.1.1.3 (QNX 6.6 VM)".
•• Note that this is a x86 VM and not a real machine.
•• This is the default target of the pre-installed projects.
•• Explore this target from the "QNX System Information" perspective.

Projects How To
•• There are three pre-installed projects that are visible on the left pane. Each one of them explained below.
•• For information on the project, expand the project and read the README file by double clicking on the file.
• To build the project, Right Click on the project name on left pane and select "Build Project". Alternatively, you

can select the project and then from the Top Menu Bar, select "Project -> Build Project".
•• You would be able to see the build progress in the bottom pane.
• To Run project A and Project B, select the project on the left pane and then press Ctrl+F11. Alternatively, you can

select the project and then from the Top Menu Bar, select "Run -> Run".
•• To Run project C, follow instructions within each sub project.
•• The projects will run on the default target 10.1.1.3.
•• In the bottom pane, you would be able to see the output of the project.
•• After running the project, just above the output you would see something like "/tmp/(project name suffixed with

some random number) on 10.1.1.3". This means that the project binary was renamed to "/tmp/(project name
suffixed with some random number)" and transferred to the QNX machine 10.1.1.3 where it was run on and the
console output was displayed on the bottom pane.

•• To terminate an running program, press the Red Square Stop Button in the bottom pane.
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Project 1: A.HelloWorld

•• This is a starter project that just prints "!!!Hello World!!!" on the console.
•• Build, Run and Debug the Project.

Project 2: B.Interrupt

•• This is a simple Interrupt Handler project.
•• Build, Run and Debug the Project.

Project 3: C.Benchmarks

•• This is a Makefile project. It contains three sub projects that not only shows how to use QNX, it does this by
providing interesting benchmark information.

•• Build the Project. To Run and Debug individual sub projects, follow the below instructions.

msgtest

•• This project tests the performance of QNX message passing, between two processes.
• To run/debug this project, Right click on the "msgtest" binary on the left pane and select "Run As/Debug As -> 1

C/C++ QNX Application"
•• Note that this test creates two copies of itself.

msgtestt

•• This project tests the performance of QNX message passing, between two threads.
• To run/debug this project, Right click on the "msgtestt" binary on the left pane and select "Run As/Debug As -> 1

C/C++ QNX Application".

udpecho & udpsend

•• This project tests the throughput of UDP packet transfers.
• First Run/debug "udpecho" by Right clicking on the "udpecho" binary on the left pane and select "Run As/Debug

As -> 1 C/C++ QNX Application".
• And then run/debug "udpsend" by Right clicking on the "udpsend" binary on the left pane and select "Run

As/Debug As -> 1 C/C++ QNX Application".
•• "udpecho" will stay running. So terminate it when you are finished by pressing the Red Square Stop Button in the

bottom pane.

Step 8: Creating a New Project
Now let's get to the real business of creating your own new project and trying your hands at C/C++ code. Pretty
simple !!
•• Go to the "C/C++" perspective.
• On the Top Menu Bar, click on "New -> C Project". A new window will open up.
•• In the new window, type the project name as "MyQNXProject". On the left pane, select "Hello World ANSI C

Project". Click on Finish.
•• Your new sample project is created.
• On the left pane, right click on "MyQNXProject" and select "Build Configurations -> Build Selected...". It will

open a new window asking you to select the build configuration. Default is "Debug". So for now, lets only check
"Debug" (uncheck everything else) and press OK.

•• The project will be build and information shown in bottom pane.
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• To Run the project, select the project on the left pane and then on the Top Menu Bar, select "Project -> Run".
Alternatively, select the project on the left pane and press Ctrl+F11.

•• In the new window, select "C/C++ QNX Application". The project will be run on QNX and the output "!!!Hello
World!!!" displayed on the bottom pane.

• To Run the project, select the project on the left pane and then on the Top Menu Bar, select "Project -> Debug".
Alternatively, select the project on the left pane and press F11.

•• To make changes to the program, Go to the "C/C++" perspective. Expand the project on the left pane. Expand
"src" directory under project and double click on the "MyQNXProject.c" file. The file would open up in the right
pane for edit.

•• Double click on the filename on the right pane and your file would take the whole screen so that its easy to write
code.

•• Replace "!!!Hello World!!!" with "#Hello QNX World#".
• Save the file by clicking "File -> Save" from the Top Menu Bar.
•• Again double click on the filename to reset to the original view.
•• Run/Debug the project to verify the output.
This is just a sample new project. You can take this project as a starting point, modify it as per your own wish, add
your own logic and make it do some real job.

Step 9: Documentation
QNX 6.6 and Momentics IDE 5.0 documentation can be found at this link. http:/ / www. qnx. com/ developers/ docs/
index. html

Step 10: Support
Direct all support requests to info@symmetry.com.au or generate a support ticket at http:/ / support. symmetry. com.
au.
Please check the below limitations before requesting support.

Limitations
•• Currently only a QNX 6.6 Virtual Machine is available for evaluation. Evaluation of real X86 and ARM targets is

available on request.
•• No root access to QNX for security reasons.
•• No admin privileges on Windows 7 Guest account for security reasons.
•• Do not leave your data on any of the machines. Please take backup regularly. We usually reset the machines

which may result in your data getting lost.

http://www.qnx.com/developers/docs/index.html
http://www.qnx.com/developers/docs/index.html
http://support.symmetry.com.au.
http://support.symmetry.com.au.
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